[C++-sig] additional files for pickle support
Ralf W. Grosse-Kunstleve
rwgk at yahoo.com
Mon Jul 22 20:34:25 CEST 2002
--- David Abrahams <david.abrahams at rcn.com> wrote:
> > I am trying to emphasize that the collection of pickle support functions
> > one type form one entity. IMO "group" (singular) does this better than
> > "functions" (plural).
> > Anyway, if you have strong opinions about this please feel free to make
> > changes you'd like to see.
> No, I just want to experiment with naming before things get too solid. A
> really good name improves the feel of a library immensely.
> So, what about "pickle_suite" (not to be confused with sweet_pickle)?
> Or more whimsically, "vinegar_and_spices" <wink>.
> Seriously, I like "suite" a little better than "group" because it has more
> of the right connotations.
OK, pickle_suite it shall be. Hang on for the patches. (And with this I will
close the chapter on naming.)
> Yep, see the end of the test Jamfile. Those tests are normally off but you
> can enable them from the command-line with -sTEST_EXPECTED_FAILURES=1
I will give it a try.
> > I am anxious to get past that transition. Mainly to make sure our
> > (non-computer scientists!) will not have to deal with "road construction
> > signs.
> Yep. I think that'll take a few days at most, and Joel has agreed to start
Cool. If we could have a stable V2 (i.e. a release) before the middle of
September that would be a tremendous benefit for us.
> Yep, it saves code generation for incref and most especially decref, which
> also generates code to destroy the object in case ob_refcnt == 0.
Thanks for the explanation!
Do You Yahoo!?
Yahoo! Health - Feel better, live better
More information about the Cplusplus-sig