Fri, 10 Nov 2000 15:10:04 +0100 (CET)
Mark Hammond writes:
> (a) I buy, but think it reasonable a convention could be to use parameters
> around callable objects, and fully qualified names. Thus "module.variable",
> "module.class", "local_class()", "local_function()" are all reasonable, and
> within the structured text spirit (IMO). It only leaves "local_variable"
> (or param, etc) requiring special treatment.
> (b) I don't really buy - it appears the exact same problem to me. The
> docstring should say "a regular file or a StringIO.StringIO() object". If
> the user took you literally, and tried to create a "StringIO" object, it
> would fail - presumably your module defines no such object.
Do you mean this should also be done for deeper package structures?
These names can become quite long and are all over the place if one
makes references to other documentstrings in a package itself.