[Python-3000] __nonzero__ vs. __bool__

tomer filiba tomerfiliba at gmail.com
Mon Nov 20 22:17:52 CET 2006


how about changing the name of __nonzero__ to __bool__?

today it looks like:
* int(x) --> x.__int__()
* long(x) --> x.__long__()
* float(x) --> x.__float__()
* str(x) --> x.__str__()

but for bool it's x.__nonzero__()

i'd guess __nonzero__ existed even before the bool type was introduced (2.2?),

but in the cleanup-old-design-issues spirit, perhaps it can be made
symmetrical
to the other builtin types.


-tomer
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.python.org/pipermail/python-3000/attachments/20061120/38523dd6/attachment.htm 


More information about the Python-3000 mailing list