[Python-3000] educational aspects of Python 3000

Neal Norwitz nnorwitz at gmail.com
Tue Sep 12 19:53:13 CEST 2006


On 9/12/06, Raymond Hettinger <rhettinger at ewtllc.com> wrote:
>
>  We could always rename raw_input() to input(). Just a thought. . .
>
>  D'oh. Guido already said he doesn't like that idea :)
>
>  FWIW, I think it is a good idea.  If there is a little 2.x vs 3.0
> confusion, so be it.   The use of input() function is already somewhat rare
> (both because of infrequent use cases and because of the stern warnings
> about eval's security issues).  It is better to bite the bullet and move on
> than it would be to avoid the most obvious name.

I agree.  Plus we are already doing something similar for {}.keys()
etc by changing them in a somewhat subtle way.  I also recall
something weird when I ripped out input wrt readline or something.  I
don't recall if I checked in the removal of {raw_,}input or not.

This is also something easy to look for and flag.  pychecker already
catches uses of input and warns about it.

n


More information about the Python-3000 mailing list