<br><br><div><span class="gmail_quote">On 5/31/06, <b class="gmail_sendername">Antoine Pitrou</b> <<a href="mailto:solipsis@pitrou.net">solipsis@pitrou.net</a>> wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Le mardi 30 mai 2006 à 09:25 -0700, Brett Cannon a écrit :<br>><br>> I think what needs to happen is decide if we want to group modules<br>> into packages (but no deeper than a single depth), and then how to<br>> handle general naming (
e.g., net.http, net.httplib, http, or<br>> httplib?).<br><br>I don't see the point of grouping modules into packages.<br>It is obvious what "http" is (a network protocol), so why have to write<br>"net.http
" instead of simply "http" ? It's more things to type and more<br>things to remember, without any clear advantage.</blockquote><div><br>That might be true of http, but what about modules with a more ambiguous name?
</div><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">The current flat namespace for the standard library is one *very*<br>pleasant feature of Python. You only have to remember the module name
<br>itself, not its position in the hierarchy. Compare this with Java<br>or .Net...</blockquote><div><br>But with Java (don't have much .NET experience) the issue is they put data structures in java.util which doesn't explain anything. But if it had been named datastruct or something more meaningful would it be so bad?
<br></div><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">Moreover, as someone wrote in another post, if you introduce packages,<br>people will write "from gui import wx", so why not just let it be
<br>"import wx"? We are adults.</blockquote><div><br>We are adults, but doesn't that mean we can also be organized? We are past the point of keeping our toys in one big basket and instead have organized shelves where we separate our Transformers from our Tonka trucks.
<br></div><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">The problem with the current naming IMO is the fact it is inconsistent<br>and sometimes confusing. I don't think introducing a level of nesting is
<br>an answer to this problem. Actually, flattening the current nested<br>modules would be a good think.</blockquote><div><br>We will be fixing the names on top of categorizing, so that will be addressed.<br></div><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
(for example, I don't like the way "os.path" is magically imported when<br>importing "os". Some functions are in "os", others in "os.path", without<br>any clear logical reason. They should all belong in "os" - or any other
<br>name for that matter).</blockquote><div><br>The magic importation is an implementation artifact from os being around before packages existed. If it was done today that wouldn't work that way.<br><br>And I would never want to flatten os completely. Knowing that path manipulating code is in
os.path is handy when you are looking for a function in the documentation, and especially at the interpreter prompt. We all know searching a tree over a list is better! =)<br></div><br>-Brett<br><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Regards<br><br>Antoine.<br><br><br>_______________________________________________<br>Python-3000 mailing list<br><a href="mailto:Python-3000@python.org">Python-3000@python.org</a><br><a href="http://mail.python.org/mailman/listinfo/python-3000">
http://mail.python.org/mailman/listinfo/python-3000</a><br>Unsubscribe: <a href="http://mail.python.org/mailman/options/python-3000/brett%40python.org">http://mail.python.org/mailman/options/python-3000/brett%40python.org
</a><br></blockquote></div><br>