how about changing the name of __nonzero__ to __bool__?<br><br>today it looks like:<br>* int(x) --> x.__int__()<br>* long(x) --> x.__long__()<br>* float(x) --> x.__float__()<br>* str(x) --> x.__str__()<br><br>but for bool it's x.__nonzero__()
<br><br>i'd guess __nonzero__ existed even before the bool type was introduced (2.2?), <br>but in the cleanup-old-design-issues spirit, perhaps it can be made symmetrical<br>to the other builtin types.<br><br><br>-tomer