[issue10273] Clean-up Unittest API
R. David Murray
report at bugs.python.org
Thu Nov 4 02:54:32 CET 2010
R. David Murray <rdmurray at bitdance.com> added the comment:
assertCountsEqual is IMO much clearer than assertItemsCountsEqual (or however you spell it). I was unclear on what the latter did, but the former is fairly clear. Ezio's suggestion is also clearer.
Raymond, since you said 'never' your statement about assertLessEqual is clearly false :). I don't have any problem remembering it (it's just __le__ spelled out using the standard unittest camelcase). assertLess, on the other hand, I often get wrong, since it is *not* __lt__ spelled out.
Python tracker <report at bugs.python.org>
More information about the Python-bugs-list