[Python-checkins] Python humor
raymond.hettinger at verizon.net
Sat Mar 4 22:23:07 CET 2006
>>I think this is a really good point. next() is supposed to get used, by
>>coders, in regular code - so it shouldn't be __next__. I can understand the
>>desire for both forms, although that seems it would clutter things up
>>unnecessarily - particularly if the two do the same thing
>> By this argument, we should be using ob.len() instead of len(ob), and
>> ob.iter() instead of iter(ob).
> Yes, I think it'd be more consistent and more object-oriented. After all
> we've switched from string.split(x, y) to x.split(y)...
LOL, Shakespearean comedy on python-dev:
* Phillip mistates Anna's position and shoots down a straw-man.
* Oleg agrees with a literal reading of Phillips note, missing the sarcasm
More information about the Python-checkins