[Python-checkins] r58975 - in python/trunk: Doc/library/collections.rst Lib/collections.py Lib/test/test_collections.py
mal at egenix.com
Thu Nov 15 13:30:59 CET 2007
On 2007-11-15 13:26, Eric Smith wrote:
> M.-A. Lemburg wrote:
>> I'm probably missing something, but why don't you name the
>> method "replace" instead of using a Python internal name for
>> it ?
> Because that would prevent you from having a namedtuple member named
Thanks for the clarification.
I usually use a single underscore for such situations, e.g.
for namespace objects, but that's probably just a matter of
>> On 2007-11-15 03:44, raymond.hettinger wrote:
>>> Author: raymond.hettinger
>>> Date: Thu Nov 15 03:44:53 2007
>>> New Revision: 58975
>>> Accept Issac Morland's suggestion for __replace__ to allow multiple
>>> (suprisingly, this simplifies the signature, improves clarity, and is
>>> comparably fast).
>>> Update the docs to reflect a previous change to the function name.
>>> Add an example to the docs showing how to override the default
>>> __repr__ method.
Professional Python Services directly from the Source (#1, Nov 15 2007)
>>> Python/Zope Consulting and Support ... http://www.egenix.com/
>>> mxODBC.Zope.Database.Adapter ... http://zope.egenix.com/
>>> mxODBC, mxDateTime, mxTextTools ... http://python.egenix.com/
:::: Try mxODBC.Zope.DA for Windows,Linux,Solaris,MacOSX for free ! ::::
eGenix.com Software, Skills and Services GmbH Pastor-Loeh-Str.48
D-40764 Langenfeld, Germany. CEO Dipl.-Math. Marc-Andre Lemburg
Registered at Amtsgericht Duesseldorf: HRB 46611
More information about the Python-checkins