[Python-Dev] PEP 376
ziade.tarek at gmail.com
Wed Jun 24 21:54:16 CEST 2009
On Wed, Jun 24, 2009 at 11:18 AM, Antoine Pitrou<solipsis at pitrou.net> wrote:
> Sridhar Ratnakumar <sridharr <at> activestate.com> writes:
>> On 09-06-23 02:57 AM, Nick Coghlan wrote:
>> > Something like DistributionDirectoryMap should cover it.
>> > You could probably get away with shortening "Directory" to "Dir" in the
>> > class names though:
>> > - Distribution
>> > - ZippedDistribution
>> > - DistributionDir
>> > - ZippedDistributionDir
>> > - DistributionDirMap
>> 'Map' reminds me of an associated hash (or is it the actual map?).
> Good thing, because it is a dict subclass if you read the PEP :)
> +1 with Nick's proposal.
I've changed using these names. Any other feedback with this PEP or
we're good to go ? :)
More information about the Python-Dev