[Python-Dev] Bits-of-Distribute naming

Chris Withers chris at simplistix.co.uk
Fri Oct 9 17:42:04 CEST 2009


Tarek Ziadé wrote:
> - The code is splitted in many packages and might be distributed under
> several distributions.
> 
>    - distribute.resources: that's the old pkg_resources, but
> reorganized in clean, pep-8 modules. This package will
>      only contain the query APIs and will focus on being PEP 376
> compatible. We will promote its usage and see if Pip wants
>      to use it as a basis. And maybe PyPM once it's open source ?
> (<hint> <hint>).
> 	It will probably shrink a lot though, once the stdlib provides PEP 376 support.

Why not just call it pkg_resources and/or merge it with pkgutil to get 
it into the python stdlib?

>    - distribute.entrypoints: that's the old pkg_resources entry points
> system, but on its own. it uses distribute.resources

Why not get it into the core as distutils.entrypoints? That's where it 
belongs...

>    - distribute.index: that's package_index and a few other things.
> everything required to interact with PyPI. We will promote
>      its usage and see if Pip wants to use it as a basis.

Why not call in "pypi.client" and "pypi.server" or, better yet, get it 
into the stdlib as disutils.index.client distutils.index.server?

>    - distribute.core (might be renamed to main): that's everything
> else, and uses the other packages.

...which would be left, and could just be called "distribute".

cheers,

Chris

-- 
Simplistix - Content Management, Batch Processing & Python Consulting
            - http://www.simplistix.co.uk


More information about the Python-Dev mailing list