Hi,<div><br></div><div>The "DirEntry" name comes from the POSIX structure "direntry". You should not instanciate the DirEntry class nor store it, so not check its type neither (isinstance(something, os.DirEntry)). I don't think that the exact name of the class matters. I had prefer DirectoryEntry, but "dir" shortcut is common in the Python os module (os.listdir) and in POSIX strandard (opendir, struct direntry).</div><div><br></div><div>You are coming late. The PEP was discussed during 3 months (may-july 2014), and Ben started to work on it since 2012! See the PEP for details:</div><div><a href="https://www.python.org/dev/peps/pep-0471/#naming">https://www.python.org/dev/peps/pep-0471/#naming</a><br></div><div><br></div>I accepted the PEP and I don't plan to modify it even if you have a serious rationale for the change. Bikeshedding is not :-) By the way, the PEP is implemnted. os.scandir() is already in the latest python 3.5 alpha. Optimized os.walk() will be in the next alpha.<br><div><br></div><div>Victor</div><div><br>Le vendredi 20 mars 2015, 罗勇刚(Yonggang Luo) <<a href="mailto:luoyonggang@gmail.com">luoyonggang@gmail.com</a>> a écrit :<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Should be replaced with os.FsEntry or os.ScanEntry<br>
<br>
--<br>
         此致<br>
礼<br>
罗勇刚<br>
Yours<br>
    sincerely,<br>
Yonggang Luo<br>
_______________________________________________<br>
Python-ideas mailing list<br>
<a href="javascript:;" onclick="_e(event, 'cvml', 'Python-ideas@python.org')">Python-ideas@python.org</a><br>
<a href="https://mail.python.org/mailman/listinfo/python-ideas" target="_blank">https://mail.python.org/mailman/listinfo/python-ideas</a><br>
Code of Conduct: <a href="http://python.org/psf/codeofconduct/" target="_blank">http://python.org/psf/codeofconduct/</a></blockquote></div>