<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">On Wed, Nov 16, 2016 at 10:48 AM, Mikhail V <span dir="ltr"><<a href="mailto:mikhailwas@gmail.com" target="_blank">mikhailwas@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class="">On 16 November 2016 at 10:27, Paul Moore <<a href="mailto:p.f.moore@gmail.com">p.f.moore@gmail.com</a>> wrote:<br>
> On 16 November 2016 at 08:51, Mikhail V <<a href="mailto:mikhailwas@gmail.com">mikhailwas@gmail.com</a>> wrote:<br>
>> What semantics it will fundamentally break or so hard to implement?<br>
><br>
> I'm afraid I don't have time at the moment to fully review your email,<br>
> but my first impression is that you are proposing that the name "self"<br>
> be treated specially. It's going to be very difficult to convince<br>
> people that this is a good idea.<br>
<br>
</span>Oh Paul, come on, pleeeeease.<br>
I am making an **example**. Write a "poo" instead or a poo pile character,<br>
whatever. You think I am an idiot and don't know that there is "self" in OOP.<br></blockquote><div><br></div><div>Maybe I should just point out a sec that saying this is a great way to get people to not listen to you.</div><div><br></div><div><br></div><div>As for your actual question: I'm not sure if I understand correctly, but I think you got things a little mixed up, or I'm not reading this the right way (also likely).</div><div><br></div><div>Let's not use self anymore as an example, since that ended in fire and brimstone. Let's use something like this:<br><br><br>A = source_var + 1</div><div><br></div><div><br></div><div>where `source_var` is a magic thing that refers to the target variable. Does that get the same idea across? Yes? Okay.</div><div><br></div><div>The main reason that this would be difficult to translate isn't difficulty, but just readability. It's weird that using source_var would use __iadd__, but anything else would use __add__.</div><div><br></div><div>Now, what I think everyone was telling you about as for "difficulty translating" is this:</div><div><br></div><div><br></div><div>A = A + 1 ==> A += 1</div><div><br></div><div><br></div><div>Similar problem: semantics change. If someone decided to be weird and have __add__ and __iadd__ do two different things, this would completely break that. Granted, that's a stupid idea to begin with, but it's still poor justification for the code breakage.</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
When I was writing that I just thought, should I make a special note<br>
that I am making it only for example, but then thought, oh that would<br>
be too pedantic.<br>
You say you have no time and write a whole page about it,<br>
so don't blame me that I take too much time from you.<br>
<span class="HOEnZb"><font color="#888888"><br>
Mikhail<br>
</font></span><div class="HOEnZb"><div class="h5">______________________________<wbr>_________________<br>
Python-ideas mailing list<br>
<a href="mailto:Python-ideas@python.org">Python-ideas@python.org</a><br>
<a href="https://mail.python.org/mailman/listinfo/python-ideas" rel="noreferrer" target="_blank">https://mail.python.org/<wbr>mailman/listinfo/python-ideas</a><br>
Code of Conduct: <a href="http://python.org/psf/codeofconduct/" rel="noreferrer" target="_blank">http://python.org/psf/<wbr>codeofconduct/</a><br>
</div></div></blockquote></div><br><br clear="all"><div><br></div>-- <br><div class="gmail_signature" data-smartmail="gmail_signature"><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div dir="ltr"><div dir="ltr">Ryan<span style="font-size:12.8px"> </span><span style="font-size:12.8px">(ライアン)</span></div><div dir="ltr">Yoko Shimomura > ryo (supercell/EGOIST) > Hiroyuki Sawano >> everyone else<br></div><div dir="ltr"><div><a href="http://kirbyfan64.github.io/" target="_blank">http://kirbyfan64.github.io/</a><div style="display:inline-block;width:16px;height:16px"> </div></div></div></div></div></div></div></div></div></div></div></div>
</div></div>