<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote">On 27 January 2017 at 22:07, Brent Brinkley <span dir="ltr"><<a href="mailto:brentbrinkley@gmail.com" target="_blank">brentbrinkley@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div style="overflow-wrap: break-word;">HI Everyone,<div><br></div><div>One issue that I’ve seen in a lot of languages struggle with is nested function calls. <br></div></div></blockquote><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div style="overflow-wrap: break-word;"><div>Parenthesis when nested inherently create readability issues.   <br></div><div><br></div></div></blockquote><div><br>Yes there is such issue. I don't see however that a radical <br>change to nested notation can be a solution here.<br>Not because it is too hard to find a consensus about how it <br>should be, but also because in some sense <br>the parenthesis nesting is sort of optimal for general case. <br><br>It is hard to explain in simple words, but some of the answers <br>gave hints already -- if you try some more complex nesting<br>with your proposed example, it will end up with even *worse* <br>schemas than parenthesis notation.<br><br>One important note about parenthesis itself: often it looks so <br>bad simply because in monospaced font, e.g. Courier, parenthesis <br>is sort of "slightly bent letter I"  which results in really bad look,<br>and the *correct* parenthesis character is a rounded bracket, <br>which extends to bottom ant top much further than letters.<br></div><div>It has thin endpoints and thicker middle. And it should be given <br>some space from left and right. <br>So a big part of the problem lies in the font. <br><br>As for the problem of long equations. Here could be many proposals.<br>My opinion: nested equations must be broken into series of smaller ones, but unfortunately<br>Python does not provide a standard solution here.<br><br>*Theoretically* I see a solution by 'inlined' statements.<br>Take a long example:<br><br>    print ( merge (a, b, merge ( long_variable2, long_variable2 ) )   <br><br>Now just split it in 2 lines:<br><br>    tmp <> merge ( long_variable2, long_variable2 )<br>    print ( merge (a, b, tmp )  )<br><br><br>So I'd for example invent a special sign which just marks <br>statements that will be first collected as inline text, sort of macros. <br>But as always, in such cases there is little chance to find <br>any consensus due to many reasons. <br>One of the reasons that there are too few good looking <br>characters out there, and same applies for any possible improvement. <br></div></div><br><br></div><div class="gmail_extra">Mikhail<br></div></div>