<div dir="ltr"><div dir="ltr"><br></div><br><div class="gmail_quote">I've lost track if who is advocating what, but:<br></div><div class="gmail_quote"><br></div><div class="gmail_quote"><span style="font-family:monospace,monospace">> >>> # Replace all "a" by "b"<br></span><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr"><div dir="ltr"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr"><div><span style="font-family:monospace,monospace">>>> v.apply(lambda s: s.replace("a", "b"))</span></div><div></div></div></blockquote></div></div></div></blockquote><div><br></div><div>I do not get the point of this at all -- we already have map"</div><div><br></div><span style="font-family:monospace,monospace">map(v, lambda s s.replace()"a,", "b")</span><div><br></div>these seem equally expressive an easy to me, and map doesn't require a custom class of anything new at all.<br></div><div class="gmail_quote"><div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr"><div dir="ltr"><div class="gmail_quote">    v.replace("a", "b")</div></div></div></blockquote><div><br></div><div>This is adding something - maybe just compactness, but I also think readability.</div><div><br></div><div>I've also lost track of whether anyone is proposing a "vector of strings' as opposed to a vector of arbitrary objects.</div><div><br></div><div>I think a vector strings could be useful and then it would be easier to decide which string methods should be applied to items vs the vector as a whole. If you want to do any generic items, it becomes a lot harder.</div><div><br></div><div>I think numpy has had the success it has because it assumes all dytpes are numerical and thus support (mostly) the same operations.</div><div><br></div><div>-CHB</div><br clear="all"></div><br>-- <br><div dir="ltr" class="gmail_signature">Christopher Barker, PhD<br><br> Python Language Consulting<br>  - Teaching<br>  - Scientific Software Development<br>  - Desktop GUI and Web Development<br>  - wxPython, numpy, scipy, Cython<br></div></div>