another candidate for deprecation (was: Why shouldinput(prompt="hello:") fail?)
aahz at pythoncraft.com
Tue Nov 25 20:09:09 CET 2003
In article <3FC388F2.8FB1B8D2 at engcorp.com>,
Peter Hansen <peter at engcorp.com> wrote:
>Skip Montanaro wrote:
>> Even better, deprecate input() and rename raw_input() to input()...
>If you mean do those two things at the same time, you've just
>deprecated the use of "input" and then provided only a routine named
>And if you mean to separate them with one release to give time for the
>deprecation notice to spread around, you'll just confuse people when
>you then add "input" back in, but with different functionality.
>(I agree with the idea of reusing the name input() for the One True
>Input Routine, but not with deprecating anything as it will just
>confuse the issue.)
Yeah, what would make more sense would be to rename input() to
eval_input() and rename raw_input() to input(), and immediately
Aahz (aahz at pythoncraft.com) <*> http://www.pythoncraft.com/
Weinberg's Second Law: If builders built buildings the way programmers wrote
programs, then the first woodpecker that came along would destroy civilization.
More information about the Python-list