On PEP 322 (ireverse)
vze4rx4y at verizon.net
Wed Oct 29 17:52:57 CET 2003
> Gonçalo Rodrigues wrote:
> > First, i like the name ireverse, much better then inreverse (eek!).
> I still prefer Werner Schiendl's idea of iter.reversed, IF we find a
> way to have builtin function iter grow a 'staticmethod' of sorts...!
No thanks. Yuck. Please do not twist this simple idea into knots.
This is supposed to be something you can teach in the first half-hour
and then use forever. I would sooner teach negative xrange()
indices than immediately launch into dotted references to a static
method attached to something that doesn't look like it should have
a method. This is a simplification, not an exercise in being cute
or clever just to avoid a builtin.
More information about the Python-list