On 5 Dec 2006 09:55:20 -0800, <b class="gmail_sendername">Steve Bergman</b> <<a href="mailto:steve@rueb.com">steve@rueb.com</a>> wrote:<br><div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
However, I am finding that the 79 character line prescription is not<br>optimal for readability.</blockquote><div><br>For me, 79 characters per line... would basically make my code a LOT<br>harder for me to read and manage. 
<br><br>I mean, a basic structure for a LOT of the code I end up working on is:<br><br>class foo:<br>    def myMethod(self, arg1):<br>        try:<br>            try:<br>                connection = ConnectionQueue.get()<br>
                ...<br>            finally:<br>                ConnectionQueue.put(connection)<br>        except:<br>            logging.exception("foo::myMethod(%s) unknown error" % arg1)<br><br>At that point, i've lost 17-characters before I even start... Even some with just a very simple SQL statement ends up with text at 85ish characters.
<br><br>I might be biased, but my screen goes otu to about 200 characters-- and I'm not writing an open source app :) If I was, I might be more inclined to doing things in a more generally-readable way... but in my office scenario, I don't have to worry about people who are only reading to 79 characters. You have to evaluate your environment/audience, both current and of what it may be in the future.
<br><br>As a rule, if it's over about 125 characters, I try to split it up into different lines.<br><br></div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
While I'm on this general topic, the guide mentions a pet peeve about<br>inserting more than one space to line up the "=" in assignment<br>statements.  To me, lining them up, even if it requires quite a few<br>extra spaces, helps readability quite a bit.  Comments?
</blockquote><div><br>I like lining up the equal statements/other punctuation for things that are all the "same". Like, if I'm using building up an event table w/ wxWidgets, I'll have all the arguments in the self.Bind
(...) line up because then it's easier to scan for me. <br></div></div>