<div class="gmail_quote">On Sun, Jan 2, 2011 at 9:52 AM, Alan Gauld <span dir="ltr">&lt;<a href="mailto:alan.gauld@btinternet.com">alan.gauld@btinternet.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">

&quot;Corey Richardson&quot; &lt;<a href="mailto:kb1pkl@aim.com" target="_blank">kb1pkl@aim.com</a>&gt; wrote<br>
<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="im">


On Sat, Jan 1, 2011 at 9:10 PM, Alan Gauld &lt;<a href="mailto:alan.gauld@btinternet.com" target="_blank">alan.gauld@btinternet.com</a>&gt; wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Why avoidCamelCase? I actually prefer it to using_non_camel_case<br>
</blockquote>
<br></div><div class="im">
Python appears to use camelCase more than not.<br>
<br>
</div></blockquote><div class="im">
<br>
I tend to disagree with that. In the stdlib, as well as the builtins,<br>
many, many methods are alllowercase, for example str.isdigit() or<br>
socket.gethostname().<br>
</div></blockquote>
<br>
Which should, according to PEP8, be get_hostname()(*) and<br>
is_digit()...<br>
<br>
The stdlib is a mess of inconsistency. I assume that&#39;s why PEP8<br>
seems to get more attention these days - it&#39;s been around for ages.<br>
Some modules use CamelCase, some use underscores and<br>
some just use long lowercase names (the worst option! - well<br>
apart from all uppercase like COBOL...!)<br></blockquote><div><br></div><div>Well, PEP8 does suggest that the preference is 1) lowercase names unless readability suffers, such as in goallist or something that can be improved, then 2) goal_list is preferred over goalList, unless 3) existing code uses theOtherWay.</div>

<div><br></div><div>Personally I feel lowercase_with_underscores to be more readable than lowercaseWithoutUnderscores, although since I took that (required) Java class my junior year, I&#39;m used to typingIncrediblyLongNamesThatAreRidiculouslyVerboseTellingYouEverythingThatTheClassOrFunctionMayOrMayNotDo, in that style of case. I am firmly convinced that Java is the reason IDEs with really good auto complete were developed ;)</div>

<div><br></div><div>I try to code according to PEP8, and write all my functions/variables using onlylowercase except when_i_cant_tell_what_that_word_is. And of course I try to make my variables as short as possible, but no shorter :)</div>

<div><br></div><div>-lowercasefully,</div><div>wayne_werner</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<br>
(*)hostname could be host_name I guess but Unix tradition<br>
spells it as one word so I&#39;ve followed that convention...<br>
<br>
Alan G <br><div><div></div><div class="h5">
<br>
_______________________________________________<br>
Tutor maillist  -  <a href="mailto:Tutor@python.org" target="_blank">Tutor@python.org</a><br>
To unsubscribe or change subscription options:<br>
<a href="http://mail.python.org/mailman/listinfo/tutor" target="_blank">http://mail.python.org/mailman/listinfo/tutor</a><br>
</div></div></blockquote></div><br>