[Web-SIG] Random thoughts
Gregory (Grisha) Trubetskoy
grisha at modpython.org
Mon Nov 3 10:07:17 EST 2003
On Mon, 3 Nov 2003, John J Lee wrote:
> On Mon, 3 Nov 2003, Steve Holden wrote:
> > On balance, your suggestion seems the most practical except for the
> > naming (form-data is not a valid name). Maybe formargs and queryargs, or
> > formdata and querydata, or some such, leaving the user to merge the two
> > sets as (and only when) required.
> 'form' seems bad because form data can be in the URL-encoded data, not
> only in the POST data. How about postdata and querydata?
I like "post" and "query" as a qualifier to "form data", after reading all
this RFC stuff, this seems most standard compliant.
request.form(query_overrides=1) <-- returns both
I think would be clear and intuitive.
More information about the Web-SIG