[Web-SIG] Status code, status header
janssen at parc.com
Thu Sep 2 21:55:38 CEST 2004
> I would say that start_response(http.METHOD_NOT_ALLOWED, headers) is
> more readable. Or:
> start_response(405, headers) # method not allowed
> is just as readable. "Method not allowed" is just a comment, it isn't
> program information. Why propagate a comment through the system?
While I tend to prefer the integer codes, I could just point out that
could map to "405 Method Not Allowed" as easily as to 405.
More information about the Web-SIG