I tried  /usr/bin/python3 -m pylint and it worked, and now it seems like pylint by itself alsow works.  Not sure what I was doing wrong, but thanks.

On Tue, May 2, 2017 at 9:28 AM Florian Bruhin <me@the-compiler.org> wrote:
Hi,

On Tue, May 02, 2017 at 02:49:50PM +0000, Thomas Nelson wrote:
> I am trying to use pylint to check python3 code.  I get "Unnecessary parens
> after 'print' keyword" for every print.
> I installed it with "pip3 install --user pylint" , and "cat $(which
> pylint)" gives
> #!/usr/bin/python3

That looks right. What does /usr/bin/python3 --version say? Does
anything change when you use /usr/bin/python3 -m pylint?

Also, what does "pylint --version" show?

> So I'm pretty sure I have the correct version.  Is there some configuration
> paramter to force python3 checking?  I couldn't find anything in the docs.
> I can just turn off that particular warning, but is that what everyone who
> uses pylint for python 3 does?

No configuration necessary, that warning definitely shouldn't get
printed if you're actually running an up-to-date pylint with python 3.

Florian

--
https://www.qutebrowser.org  | me@the-compiler.org (Mail/XMPP)
   GPG: 916E B0C8 FD55 A072  | https://the-compiler.org/pubkey.asc
         I love long mails!  | https://email.is-not-s.ms/