I can't install releases of packages from devpi other than the latest release.

All releases show up in the listening:
$ devpi list package
http
://devpi.corporate.com/orangetux/dev/+f/d15/d668a6cffc273/package-0.6.1-py2.py3-none-any.whl
http
://devpi.corporate.com/orangetux/dev/+f/f9b/9f520a2c17633/package-0.6.0-py2.py3-none-any.whl
http
://devpi.corporate.com/orangetux/dev/+f/7f1/5c7b906eace44/package-0.5.0-py2.py3-none-any.whl


Installing version 0.6.1 goes without problem, but instaling an older release is not possible:

$ pip install --upgrade --trusted-host devpi.corporate.com --find-links http://devpi.corporate.com/dev --no-index package==0.6.0
Ignoring indexes: https://pypi.python.org/simple
Collecting package==0.6.0
 
Could not find a version that satisfies the requirement package==0.6.0 (from versions: 0.6.1)
No matching distribution found for package==0.6.0


Is their something I'm missing?