On Mon, Jun 8, 2009 at 5:23 PM, Ronald Oussorenronaldoussoren@mac.com wrote:
On 8 Jun, 2009, at 8:16, Tarek Ziadé wrote:
On Mon, Jun 8, 2009 at 5:11 PM, Paul Moorep.email@example.com wrote:
2009/6/8 Ronald Oussoren firstname.lastname@example.org:
I guess the problem only occurs if "egg_infos" is part of the public interface. What if module A calls get_egg_infos(), then module B calls get_egg_infos(somePath), then module A uses "egg_infos" assuming that it still refers to the same set of paths.
Vaguely off-topic, but is it only me that hates the abbreviation "infos"? It can only realistically be an abbreviation for the word "informations" - and there's no such word :-(
Mmm, that's my frenglish, Sir ;) (If you see other weird stuff please let me know)
So I guess "get_egg_info" is the shortest, proper form ?
The thingy we're getting is called an "EggInfo", which would IMHO mean that "get_egg_infos" is technically the correct name for something that returns a list of them. I'd interpret the singular form as a function that returns one EggInfo object.
I have a problem now with the EggInfo name, because of the repetition:
I think EggInfo could be renamed to something better, like DistInfo maybe, (not PkgInfo because it handles more that PKG-INFO)