I have a library that depends on ElementTree and needs to support both Python2.4 and Python2.5 style inclusion of the library.
In Python2.4, it's a standalone package and can be fetched by "elementtree>=1.2". In Python2.5, it's integrated into the standard library as xml.etree.
If I pass "elementtree>=1.2.6" in install_requires, setuptools downloads the Python2.4 standalone version of the package under Python2.5.
Any way I can express a dependency on elementtree if and only if I'm installing into 2.4?