On Thu, Jun 18, 2009 at 10:17 AM, David Lyon <david.lyon@preisshare.net> wrote:

This is kind of typical of what I get all the time...

Platform: XP-Python 2.5

Running installer ... C:\Python25\scripts\easy_install.exe asciiporn
Searching for asciiporn

Exception: asciiporn requires Python 2.6 or higher

Processing asciiporn-2009.05.01.tar.gz
Running asciiporn-2009.05.01\setup.py -q bdist_egg --dist-dir

What's wrong with that ?

If you look at ascii porn setup.py file, it has an explicit test on the python version:

if sys.version_info[1] < 6: raise Exception("asciiporn requires Python 2.6 or higher")

So you have to easy_install it on Python 2.6, not Python2.5, or to ask asciiporn maintainer
to backport it to 2.5