On Tue, Aug 20, 2019, at 3:50 PM, Brian Skinn wrote:
I wonder if there's an OS dependence here, though -- I'm almost certain I've had to use `--only-binary` in the past, to avoid pip on my Windows machines trying to download and build sdists, even when wheels were available.

Possibly you were trying to install something where the latest version didn't have a compatible wheel you could use, but an older version did. I think pip will prefer a newer version even if that means building from source.

Thomas