On Thu, Oct 19, 2017, at 09:04 PM, Donald Stufft wrote:
Like I said, I’m perfectly fine documenting that if you add an entry_points.txt to the .dist-info directory, that is an INI file that contains a section named “console_scripts” and define what is valid inside of the console_scripts section that it will generate script wrappers, then fine. But we should leave any other section in this entry_points.txt file as undefined in packaging terms, and point people towards setuptools for more information about it if they want to know anything more than what we need for packaging.
I don't see any advantage in describing the file format but then pretending that there's only section in it. We're not prescribing any particular meaning or use for other sections, but it seems bizarre to not describe the possibilities. console_scripts is just one use case. Also, entry points in general kind of are a packaging thing. You specify them in packaging metadata, both for setuptools and flit, and the packaging tools write entry_points.txt. It's not the only way to create a plugin system, but it's the way this one was created. I honestly don't get the resistance to documenting this as a whole. I'm not proposing something that will add a new maintenance burden; it's a description of something that's already there. Can't we save the energy for discussing a real change or new thing? Thomas