I joined the list after this discussion:

http://mail.python.org/pipermail/distutils-sig/2010-March/015607.html

and want to point out that even the most recent versions of Zope 2.x for example still recommend Python 2.4.

http://www.zope.org/Products/Zope/2.11.4/Zope-2-11-4-released

In other words, there are probably alot of web apps out there (eg think about sites on Plone CMS) potentially running Python 2.4.  I run a dedicated Python 2.4 just for Plone for example (the buildout of which is based on virtualenv and setuptools anyway I guess).

Whether distutils2 would be used by these projects of course is another matter.  Just pointing out Python 2.4 is absolutely not unimportant.