[Distutils] Why is requiring version 0.0.1 when both 0.0.1 and 0.0.2 are available a conflict?