On Thu, Dec 23, 2010 at 9:25 PM, "Martin v. L÷wis" <martin@v.loewis.de> wrote:
Am 23.12.2010 20:00, schrieb cool-RR:
> I'm making a release of my project today, and I noticed that the MSI
> created by Python 2.7 when doing `bdist_msi` does not seem to be
> attached to a specific Python version.
>
> Is it safe to supply it for users of Python 2.5-2.7? (My package is
> pure-Python.)

Yes, that's the intention. The feature has seen little testing so far,
so feedback is welcome.

> When uploading to PyPI, I'm forced to choose a single Python version for
> the MSI.

How so? Because it says that it's needed, or because you get an error
message when you specify "any"? If so, what error message exactly?

Regards,
Martin

I tried submitting without a Python version at all. and it gave an error.

Now I did "any Python version," which worked, and I noted in the comments that it's intended for 2.5-2.7. So I guess I'm okay.


Thanks for your help,
Ram.