Good afternoon,

I hope you can assist.  I have decided to learn some programming and have downloaded Python as it appears to offer the advantage of being logical without being over complicated.

I have installed Python 3.4 on my Mac which is running OS X 10.10.1 Yosemite.  

When I open the program Idle I get the message

>>> WARNING: The version of Tcl/Tk (8.5.9) in use may be unstable.
Visit http://www.python.org/download/mac/tcltk/ for current information.

I tried typing in some lines of code copied from a Python tutorial I found on the Python website
Although the code ran OK on the tutorial website it produced errors when I typed it in Idle.

I visited the site quoted in the error message and as a result of information given there I downloaded and installed Wish 8.6 which has version Tcl 8.6 & Tk 8.6 (8.6.3)

However I still got the same error message.  I, therefore, uninstalled Python and downloaded it again from the Python website and reinstalled it in the hope that it would recognise the new version of Tcl/Tk.
But, the same error message still appears.  The program Idle does not seem to recognise that I have Tcl8.6 &Tk 8.6.3 installed instead of Tcl/Tk 8.5.9

There must be a simple error I am making, but I do not know what it is.  

This is the first time that I have tried anything like programming and I would appreciate assistance if possible.

Kind Regards

Peter McCahy