
June 29, 2013
12:50 p.m.
This should not be called a "mutable sequence of integers", because to call them "integers" already casts raw bits into a particular *type*. They could, hypothetically be very short floats, for example.
More accurately, they are merely "uninterpreted bits presented to the user in 8-bit chunks, with a consistent starting boundary" (held by the machine storage address).
Perhaps a better suggestion is to call them an 'uninterpreted sequence of bits, presented to the user in 8-bit "chunks" (i.e. bytes).' -- MarkJ Tacoma, Washington