Chris Jerdonek added the comment:
Here is an updated patch. The changes I made are:
(1) Update code comments in _call_popen_and_assert(). (2) Fix test failure. (3) Rename _call_popen_and_assert() to _assert_cwd() since it is a simpler name and the old name did not reflect that the method is specific to the test_cwd_* methods. (4) Add _split_python_path() helper method so that we do not need to call os.path.realpath(sys.executable) in every method.
Andrew, you can make changes re: Tru64 (removing old code, etc). Thanks.
---------- Added file: http://bugs.python.org/file27115/issue-15533-5-default.patch