Matthew Cowles firstname.lastname@example.org added the comment:
My thanks to David for the clarification. I don't find the logic he describes (but does not necessarily subscribe to!) persuasive in this case. In my opinion, "Let's be incorrect for the sake of simplicity," is not the way to document a programming language in the language's official library documentation.
I think that saying, "If the object (technically the class) has a method named..." would add very little burden to people who don't care about the difference.