[issue36355] Remove documentation and internal use of the RESTRICTED constants for PyMemberDef's flags field
New submission from Josh Rosenberg <shadowranger+python@gmail.com>: While looking up background info for #36347, I noticed that the docs for PyMemberDef ( https://docs.python.org/3/extending/newtypes.html#generic-attribute-manageme... ) define the following flags: * READONLY * READ_RESTRICTED * WRITE_RESTRICTED * RESTRICTED Of those, WRITE_RESTRICTED has been documented incorrectly since Python 3.0a2 (it got renamed to PY_WRITE_RESTRICTED in structmember.h, apparently due to a name clash with VS 2008 on Windows). Luckily, the constants are useless; AFAICT they were there solely to support restricted mode (via the rexec and Bastion modules). The modules were apparently disabled in Python 2.3 "due to various known and not readily fixable security holes" ( https://docs.python.org/2/library/restricted.html ), and the modules themselves officially deprecated in 2.6, and removed completely in 3.0. Rather than fixing up the docs, maybe it's time to kill these constants for good? Probably shouldn't remove the definitions in structmember.h (if someone wrote code using them, we shouldn't needlessly break compilation), but the interpreter and standard library should stop setting them, and the documentation for them should be removed. ---------- assignee: docs@python components: Documentation, Extension Modules, Interpreter Core messages: 338282 nosy: docs@python, josh.r priority: normal severity: normal status: open title: Remove documentation and internal use of the RESTRICTED constants for PyMemberDef's flags field versions: Python 3.8 _______________________________________ Python tracker <report@bugs.python.org> <https://bugs.python.org/issue36355> _______________________________________
Josh Rosenberg <shadowranger+python@gmail.com> added the comment: To be clear, only the constants that include the substring RESTRICTED are useless; READONLY remains useful and should not be removed (though per my suggestion on #36347, it might be good to add an alias for it named PY_READONLY to match the Python C API naming conventions). ---------- title: Remove documentation and internal use of the RESTRICTED constants for PyMemberDef's flags field -> Remove documentation and internal use of the *RESTRICTED constants for PyMemberDef's flags field _______________________________________ Python tracker <report@bugs.python.org> <https://bugs.python.org/issue36355> _______________________________________
Stéphane Wirtel <stephane@wirtel.be> added the comment: Josh, I don't know for the uselessness or not of these macros, but these macros are used. RESTRICTED is used in Objects/classobject.c and Objects/funcobject.c PY_WRITE_RESTRICTED is used in Objects/funcobject.c and Objects/methodobject.c ---------- nosy: +matrixise _______________________________________ Python tracker <report@bugs.python.org> <https://bugs.python.org/issue36355> _______________________________________
Josh Rosenberg <shadowranger+python@gmail.com> added the comment: Yes, they're set. They're never *read* anywhere. My suggestion was to stop setting them (because it gives the impression they do something when reading the docs, when in fact they do nothing), and remove them from the docs. ---------- _______________________________________ Python tracker <report@bugs.python.org> <https://bugs.python.org/issue36355> _______________________________________
Josh Rosenberg <shadowranger+python@gmail.com> added the comment: Sorry, that should have been "it gives the impression they do something when reading the *source code*" ---------- _______________________________________ Python tracker <report@bugs.python.org> <https://bugs.python.org/issue36355> _______________________________________
participants (2)
-
Josh Rosenberg
-
Stéphane Wirtel