Sept. 5, 2006
4:33 p.m.
Furthermore, the flow is not the same as with today's raw_input().
I don't like it.
While I totally agree with the proposed removal of input() [anything using eval() in a hidden way is *bad*], my preference would be to keep raw_input()'s functionality, perhaps renaming it to user_input() or ask_user().
I agree. Apart from the name raw_input() is a nice thig to have. It was the first annoyance when I started with Java in school, to find it doesn't have anything like it. Even sys.stdin is impractical in Java. ask_user() or user_input() are good names. Christian