On 9/8/06, Douglas S. Blank <dblank@brynmawr.edu> wrote:
Kirby,
As a teacher, I don't have time to argue over on python-dev what should and should not be included in the language. And don't want to! I am thinking of our "petition nonsense" as a data point for those people that do take the time over on python-dev to figure out the best thing to do next, and I'll trust them.
As a teacher, I don't want other teachers meddling with our snake on a "don't have time" basis -- except in their individual capacities. As "petition signers" I have no interest in them.
It seemed to at least a few people on the list that python-dev'ers may not have fully considered the ramifications of this particular change in regards to teaching. We simply want to let them know about this oversight. John has written probably the best-selling textbook for intro Python; if he is concerned, then they should at least take a second look at it (whatever "it" might be.)
John gets my respect and attention, but that doesn't mean he adds any weight to his views by circulating a petition (which, for the record *he has not done*). The minute he politicizes it in this way, I start to lower my opinion.
As far as I understood the discussion about removing "print", it was to remove it as an expression and add it as a function. This is a good move (in my opinion) because it is now even more parallel with input(), and makes more sense, and makes it more useful. If the discussion was to turn "print" into "sys.stdout.write()" then I think some teachers would again be upset, and rightly so. Maybe they should rename it output() though. :)
I'm sick of these "teachers" you keep talking about. They should all just go away, and let the real programmers have their jobs. Don't even *think* about teaching Python if you haven't coded in it professionally and made real money off it. That's closer to my attitude than "oh, the teachers are upset, we should care."
Now, it's time for the semester to begin... ACK
-Doug
I hope we continue ignoring "teachers" completely, but not John Zelle. I also listen to Arthur and Dethe. Kirby