Hi Slava,

Indeed your suggestion worked. What I was missing was the final compilation after installing the build-essential tools.
Thanks a lot!

--- oOo ---

Alessandro Lodi | Clarendon Scholar | DPhil Student |

Trinity College, 
University of Oxford,

+44 (0) 7517 549419 (UK Mobile)

+39 334 3282421 (ITA Mobile)

--- oOo ---

On Wed, 3 Feb 2021 at 12:18, Viacheslav Ostroukh <kwant_dev@slavouti.ch> wrote:
Dear Alessandro,

I assume you installed Kwant from pip, since if you installed it from
conda/conda-forge you would probably not have problems with MUMPS. In
pip Kwant is distributed from source codes and needs to find MUMPS in
the system. To build it, you need to install:

    apt install build-essential python3-dev libmumps-seq-dev
    pip install kwant sympy matplotlib

Then on a fresh Ubuntu 20.04 everything seems to install fine and
without extra configuration.

Hope that helps,

On 02/02/2021 16:07, alessandro.lodi@materials.ox.ac.uk wrote:
> Hi guys,
> I'm running kwant on WSL2 Ubuntu 20.04 and I followed along with your installation procedure.
> I've tried to follow along with the examples you provide on the website and the workshop you had a couple of months ago and when it's time to calculate smatrix.transmission(1, 0) for a very simple 1-D scattering problem it doesn't.
> When I run the python test I get a few errors back, mainly from the test_mumps.py source.
> I understand it's a bit vague said in this way but I have tried to copy and paste the screenshot of my error and the text file but it seems the post window doesn't allow such thing.
> I'm a beginner, so any help would be appreciated.
> Thanks a lot,