[lxml] Dropping Python 2.3 support