On 2014-06-25 16:59, Mark Sapiro wrote:
On 06/25/2014 03:09 AM, Tomasz Chmielewski wrote:
I've updated Apache to 2.4, and my mailman installation refuses to work with the following information:
Mailman CGI error!!! The Mailman CGI wrapper encountered a fatal error. This entry is being stored in your syslog:
Operation not permitted
What if anything is in the Apache error_log?
Absolutely nothing in Apache error_log.
I found the cause:
It works fine if I use apache2-mpm-prefork, but fails if I use apache2-mpm-itk[1].
ITK lets you choose a user which executes any given vhost and I prefer to run this version.
With older Apache version, Mailman was working fine with Apache-ITK. Here, something's missing and doesn't work.
I'll try your other suggestions to see if I can get more information.
The only things I see in logs is basically the same as above:
Jun 25 11:59:37 web1 Mailman cgi-wrapper (listinfo): Operation not permitted Jun 25 12:01:15 web1 Mailman cgi-wrapper (admin): Operation not permitted
I've tried stracing Apache process to see where it might get permission issues, but I don't see anything like it.
Does anyone have a clue how to fix it?
The cgi-wrapper is invoked by the web server. It checks the callers group and then calls scripts/driver which in turn runs the actual Mailman/Cgi/* script.
Normally, exceptions encountered by the admin.py, listinfo.py, etc. script are reported by the driver with a full traceback.
It seems in this case the driver script encounters the Operation not permitted exception either before or in the process of trying to print a traceback.
See the comments at the beginning of scripts/driver.
You can manually run as root or a user in Mailman's group
export REQUEST_METHOD=GET python /path/to/scripts/driver listinfo
and see what that produces.
-- Tomasz Chmielewski http://www.sslrack.com