Trivial prob in migrating
Hi all
This must be triavial. Our mailman installation worked too good, too long. So we forgot its details. Now we are mirgrating to a new (virtual) server and I'm faced this problem.
Old box: slackware 12.0, mailman installed from sources New box: Ubuntu Server 2009.4, mailman got with apt-get, the standard exim was replaced by postfix, also through apt.
This is roughly what I did:
copied old:/usr/local/mailman/{lists|archives|data} to new:/var/lib/mailman/
chown -R list /var/lib/mailman/{lists|archives|data}
/etc/init.d/mailman start and I get "IOError: [Errno 13] Permission denied: '/var/lib/mailman/lists/mailman/config.pck"
checking the privileges -rw-rw---- 1 root klog 3660 2009-07-27 17:18 config.pck
its odd pending.pck and request.pck are owned by list:klog and have timestamps 2008-10-21. Deleting config.pck didn't help, it was recreated with the identical permissions.
What is missing?
Second question: How do I create all the special strings needed by postfix?
best regards Viz
viz@lug.zhaw.ch wrote:
This is roughly what I did:
copied old:/usr/local/mailman/{lists|archives|data} to new:/var/lib/mailman/
chown -R list /var/lib/mailman/{lists|archives|data}
You must chgrp to Mailman's group
- /etc/init.d/mailman start and I get "IOError: [Errno 13] Permission denied: '/var/lib/mailman/lists/mailman/config.pck"
checking the privileges -rw-rw---- 1 root klog 3660 2009-07-27 17:18 config.pck
its odd pending.pck and request.pck are owned by list:klog and have timestamps 2008-10-21. Deleting config.pck didn't help, it was recreated with the identical permissions.
What is missing?
Changing the group may be enough, but if you've lost the SETGID bit, you need to set that too. Mailman's bin/check_perms should help.
Second question: How do I create all the special strings needed by postfix?
Make sure you have
MTA = 'Postfix'
in mm_cfg.py and run Mailman's bin/genaliases. See <http://www.list.org/mailman-install/node12.html>.
-- Mark Sapiro <mark@msapiro.net> The highway is for gamblers, San Francisco Bay Area, California better use your sense - B. Dylan
Hi Mark and all
That problem was solved, although not exactly according to your instructions (see details below). I have another prob at the bottom of this mail.
Ref: Mark Sapiro <mark@msapiro.net> 28.07.2009 16:07
viz@lug.zhaw.ch wrote:
This is roughly what I did:
copied old:/usr/local/mailman/{lists|archives|data} to new:/var/lib/mailman/
chown -R list /var/lib/mailman/{lists|archives|data}
You must chgrp to Mailman's group
In this Debian fresh installation, there is user and group called list. The files in /var/lib/mailman itself is root:list, files/directories inside have all sorts of ownerships: root:root, list:list, root:list, list:klog, ???
- /etc/init.d/mailman start and I get "IOError: [Errno 13] Permission denied: '/var/lib/mailman/lists/mailman/config.pck"
checking the privileges -rw-rw---- 1 root klog 3660 2009-07-27 17:18 config.pck
its odd pending.pck and request.pck are owned by list:klog and have timestamps 2008-10-21. Deleting config.pck didn't help, it was recreated with the identical permissions.
What is missing?
Changing the group may be enough, but if you've lost the SETGID bit, you need to set that too. Mailman's bin/check_perms should help.
Changing the ownership helped. Possibly not the best solution.
Second question: How do I create all the special strings needed by postfix?
Make sure you have
MTA = 'Postfix'
in mm_cfg.py and run Mailman's bin/genaliases. See <http://www.list.org/mailman-install/node12.html>.
Thanks. That was missing. I just bin/genaliases >> /etc/aliases and ran newaliases.
That part is sofar OK.
The next question is the archives.
http://server/cgi-bin/mailman/listinfo brings me:
Bug in Mailman version 2.1.9 We're sorry, we hit a bug! Please inform the webmaster for this site of this problem. Printing of traceback and other system information has
/var/lib/mailman/log/error has amoung other things file /usr/lib/mailman/Mailman/MailList.py line 595 fp = open(dbfile) IOError: Errorno 13 Permission denied /var/lib/mailman/lists/mailman/config.pck
Again permissions?
Viz
viz wrote:
The next question is the archives.
http://server/cgi-bin/mailman/listinfo brings me:
Bug in Mailman version 2.1.9 We're sorry, we hit a bug! Please inform the webmaster for this site of this problem. Printing of traceback and other system information has
/var/lib/mailman/log/error has amoung other things file /usr/lib/mailman/Mailman/MailList.py line 595 fp = open(dbfile) IOError: Errorno 13 Permission denied /var/lib/mailman/lists/mailman/config.pck
Again permissions?
Have you run bin/check_perms?
If not, please run it as root with -f until it runs clean. It will fix all sorts of problems. The problem above could be that the cgi-bin/listinfo wrapper is not group 'list' and SETGID or the 'list group does not have access to the /var/lib/mailman/lists/mailman/config.pck file.
-- Mark Sapiro <mark@msapiro.net> The highway is for gamblers, San Francisco Bay Area, California better use your sense - B. Dylan
participants (3)
-
Mark Sapiro -
viz -
viz@lug.zhaw.ch