Mailman 2.0.7 has been working fine on a RED HAT 7.2 machine without a configuration change and all of a sudden it's not delivering messages, all of the messages have been just setting in the /home/mailman/qfiles directory. No configuration changes have been made. I stopped sendmail and restart it and that did not fix the problem. I also rebooted the Linux Box, problem still occurs. I can send an email through the command line using sendmail and that works, also I have majordomo installed on this box and Majordomo works fine. They have both been on this system forever and both have worked fine. Also /var/log/maillog does not report any errors or anything abnormal. The /home/mailman/locks directory is empty, so there is no stalled process. The Qrunner cron job is runner every minute it shows up in the /var/log/cron file with no errors.
The log reports in /home/mailman/logs are reporting these error messages. POST file Nov 29:42:00 2001 (3443) post to korymail from wheakory@isu.edu, size=441 2 failures
SMTP file Nov 29 09:46:01 2001 (3452) smtp for 94 recips, completed in 0.006 seconds Nov 29 09:46:01 2001 (3452) All recipients refused: (111, 'Connection refused')
SMTP-FAILURE file Nov 29 09:50:00 2001 (3470) -1 wheakory@isu.edu (ignore)
Any solutions?
######################################### Kory Wheatley Academic Computing Analyst Sr. Phone 282-3874 ######################################### Everything must point to him.
On 29 November 2001, Kory Wheatley said:
Mailman 2.0.7 has been working fine on a RED HAT 7.2 machine without a configuration change and all of a sudden it's not delivering messages, all of the messages have been just setting in the /home/mailman/qfiles directory. [...] SMTP file Nov 29 09:46:01 2001 (3452) smtp for 94 recips, completed in 0.006 seconds Nov 29 09:46:01 2001 (3452) All recipients refused: (111, 'Connection refused')
SMTP-FAILURE file Nov 29 09:50:00 2001 (3470) -1 wheakory@isu.edu (ignore)
Is someone listening to port 25? What happens if you
telnet localhost 25
on the host in question? (I assume your Mailman host and mail server are the same host.)
Try a simple SMTP session, emulating what Mailman does, eg.
EHLO localhost MAIL FROM:<test-admin@your.domain> RCPT TO:<blahblah@example.com>
Any clue?
Greg
-- Greg Ward - software developer gward@mems-exchange.org MEMS Exchange http://www.mems-exchange.org
participants (2)
-
Greg Ward -
Kory Wheatley