On Wed, Jul 6, 2016 at 2:57 PM, Eric Firing firstname.lastname@example.org wrote:
On 2016/07/06 8:25 AM, Benjamin Root wrote:
I wouldn't have the keyword be "where", as that collides with the notion of "where" elsewhere in numpy.
Agreed. Maybe "side"?
I have tentatively changed it to "pos". The reason that I don't like "side" is that it implies only a subset of the possible ways that that the position of the new dimensions can be specified. The current implementation only puts things on one side or the other, but I have considered also allowing an array of indices at which to place new dimensions, and/or a dictionary keyed by the starting ndims. I do not think "side" would be appropriate for these extended cases, even if they are very unlikely to ever materialize.
(I find atleast_1d and atleast_2d to be very helpful for handling inputs, as Ben noted; I'm skeptical as to the value of atleast_3d and atleast_nd.)
NumPy-Discussion mailing list NumPy-Discussion@scipy.org https://mail.scipy.org/mailman/listinfo/numpy-discussion