Dear Jeff,

Thanks a lot for your reply. I think it might be related with the memory management on our sever. But anyway, as you suggested, I open an issue on netcdf4-python.google.com. you can find the data and script on ftp://ftp.cea.fr/incoming/y2k01/chaoyue/. The cal_cmi_big.py gave the core dumped error, in which I tried to operate with big files (~2G). The cal_cmi_small.py works fine, which  handles data only ~25M (a subset of big files). I used a small function (which use NetCDF4) in the script to read and write nc data with NetCDF4. You can also find this function in ncfunc.py. I tested all the script and data before I upload on our ftp.

thanks again for your help,

cheers,

Chao

2012/5/26 Jeff Whitaker <jswhit@fastmail.fm>
On 5/26/12 5:51 AM, Chao YUE wrote:
Dear all,

Previously I am able to run a script on our server but now it gave me a Segmentation fault (core dumped) error.
try I tried the script with same type of netcdf file but with much smaller file size and it works. So I think the error is related with memory stuff.
I guess it's because our system administrator make some change somewhere and that cause my problem?
the file size that cause the error to appear is 2.6G (in the script I read this file with NetCDF4 to numpy array and make some manipulation),
the small one without error is only 48M.

Chao:  Without seeing your script, there's not much I can say.  I suggest opening an issue at netcdf4-python.google.com, including your script as an attachment.  You'll probably have to post the data file somewhere (dropbox perhaps?) so I can run the script that triggers the segfault.  

-Jeff



--
***********************************************************************************
Chao YUE
Laboratoire des Sciences du Climat et de l'Environnement (LSCE-IPSL)
UMR 1572 CEA-CNRS-UVSQ
Batiment 712 - Pe 119
91191 GIF Sur YVETTE Cedex
Tel: (33) 01 69 08 29 02; Fax:01.69.08.77.16
************************************************************************************