Dear all,

Previously I am able to run a script on our server but now it gave me a Segmentation fault (core dumped) error.
try I tried the script with same type of netcdf file but with much smaller file size and it works. So I think the error is related with memory stuff.
I guess it's because our system administrator make some change somewhere and that cause my problem?
the file size that cause the error to appear is 2.6G (in the script I read this file with NetCDF4 to numpy array and make some manipulation),
the small one without error is only 48M.

I tried to use "limit" command to list the following, then I change stacksize to unlimited and the problem still occurs.

ychao@obelix2 - ...CRU_NEW - 12 >limit
cputime      unlimited
filesize     unlimited
datasize     unlimited
stacksize    10240 kbytes
coredumpsize 0 kbytes
memoryuse    unlimited
vmemoryuse   unlimited
descriptors  1024
memorylocked 64 kbytes
maxproc      1024

would anybody be able to give me a short explanation  or direct me to some webpage which can help to understand the problem?

thanks et cheers,


Chao YUE
Laboratoire des Sciences du Climat et de l'Environnement (LSCE-IPSL)
Batiment 712 - Pe 119
91191 GIF Sur YVETTE Cedex
Tel: (33) 01 69 08 29 02; Fax: