Jochen Küpper wrote:
Is there any good reason to not rename Convolve.cross_correlate to correlate? That fits the other names much better.
If needed (aka backwards-compatibility to numpy) we could even provide an alias cross_correlate -- probably documented to be deprecated... But since you have to load a separate module anyway, I think we can rename the function just as well.
Please do this.