![](https://secure.gravatar.com/avatar/837d314801b4f1400d6eabc767ca2cac.jpg?s=120&d=mm&r=g)
July 7, 2014
2:27 a.m.
On Sun, Jul 6, 2014 at 6:06 PM, Eric Firing <efiring@hawaii.edu> wrote:
(I'm not entirely convinced np.arr() is a good idea at all; but if it is, it must be kept simple.)
If you are going to introduce this functionality, please don't call it np.arr. Right now, np.a<tab> presents you with a whopping 53 completion choices. Adding "r", narrows that to 21, but np.arr<tab> completes to np.array right away. Please don't introduce another bump in this road. "Namespaces are one honking great idea -- let's do more of those!" I would suggest calling it something like np.array_simple or np.array_from_string, but the best choice IMO, would be np.ndarray.from_string (a static constructor method).