Remove deprecated skiprows

Should skiprows be removed? if skiprows: warnings.warn(\ "The use of `skiprows` is deprecated, it will be removed in numpy 2.0.\n" \ "Please use `skip_header` instead.", DeprecationWarning) skip_header = skiprows Its been deprecated since 1.4. Personally, I like skiprows better than skip_header ;) Chuck

On Mon, Apr 4, 2011 at 2:20 AM, Charles R Harris <charlesr.harris@gmail.com> wrote:
Should skiprows be removed?
if skiprows: warnings.warn(\ "The use of `skiprows` is deprecated, it will be removed in numpy 2.0.\n" \ "Please use `skip_header` instead.", DeprecationWarning) skip_header = skiprows
Its been deprecated since 1.4. Personally, I like skiprows better than skip_header ;)
It's a bit late now for 1.6, could you remove it only in trunk? Ralf

On Sun, Apr 3, 2011 at 8:20 PM, Charles R Harris <charlesr.harris@gmail.com> wrote:
Should skiprows be removed?
if skiprows: warnings.warn(\ "The use of `skiprows` is deprecated, it will be removed in numpy 2.0.\n" \ "Please use `skip_header` instead.", DeprecationWarning) skip_header = skiprows
Its been deprecated since 1.4. Personally, I like skiprows better than skip_header ;)
+1 for skiprows. I always have to look it up. Skipper

On Tue, Apr 5, 2011 at 11:45 PM, Skipper Seabold <jsseabold@gmail.com> wrote:
On Sun, Apr 3, 2011 at 8:20 PM, Charles R Harris <charlesr.harris@gmail.com> wrote:
Should skiprows be removed?
if skiprows: warnings.warn(\ "The use of `skiprows` is deprecated, it will be removed in numpy 2.0.\n" \ "Please use `skip_header` instead.", DeprecationWarning) skip_header = skiprows
Its been deprecated since 1.4. Personally, I like skiprows better than skip_header ;)
+1 for skiprows. I always have to look it up.
To me one is not much better than the other, but -1 for skiprows because un-deprecating it and deprecating skip_header is inconsistent and annoying for users. Ralf

On Apr 5, 2011, at 11:52 PM, Ralf Gommers wrote:
On Tue, Apr 5, 2011 at 11:45 PM, Skipper Seabold <jsseabold@gmail.com> wrote:
On Sun, Apr 3, 2011 at 8:20 PM, Charles R Harris <charlesr.harris@gmail.com> wrote:
Should skiprows be removed?
if skiprows: warnings.warn(\ "The use of `skiprows` is deprecated, it will be removed in numpy 2.0.\n" \ "Please use `skip_header` instead.", DeprecationWarning) skip_header = skiprows
Its been deprecated since 1.4. Personally, I like skiprows better than skip_header ;)
+1 for skiprows. I always have to look it up.
To me one is not much better than the other, but -1 for skiprows because un-deprecating it and deprecating skip_header is inconsistent and annoying for users.
-1 for skiprows. When I introduced skip_footer, it looked more consistent to have a skip_header and skip_footer than a skiprows and a skip_footer. Now, we could probably find more meaningful names, like, skip_header_rows... OK, just joking.

On Tue, Apr 5, 2011 at 6:05 PM, Pierre GM <pgmdevlist@gmail.com> wrote:
On Apr 5, 2011, at 11:52 PM, Ralf Gommers wrote:
On Tue, Apr 5, 2011 at 11:45 PM, Skipper Seabold <jsseabold@gmail.com> wrote:
On Sun, Apr 3, 2011 at 8:20 PM, Charles R Harris <charlesr.harris@gmail.com> wrote:
Should skiprows be removed?
if skiprows: warnings.warn(\ "The use of `skiprows` is deprecated, it will be removed in numpy 2.0.\n" \ "Please use `skip_header` instead.", DeprecationWarning) skip_header = skiprows
Its been deprecated since 1.4. Personally, I like skiprows better than skip_header ;)
+1 for skiprows. I always have to look it up.
To me one is not much better than the other, but -1 for skiprows because un-deprecating it and deprecating skip_header is inconsistent and annoying for users.
-1 for skiprows. When I introduced skip_footer, it looked more consistent to have a skip_header and skip_footer than a skiprows and a skip_footer. Now, we could probably find more meaningful names, like, skip_header_rows... OK, just joking.
I'm only slightly serious here, but inconsistent keywords are also annoying for users. e.g. vs. numpy.loadtxt, though I know that the use cases are slightly different. To my mind, skip_headers is a bool and skiprows is (more general and) an int. Using R too much maybe. Skipper

On Apr 6, 2011, at 12:16 AM, Alan G Isaac wrote:
On 4/5/2011 6:11 PM, Skipper Seabold wrote:
To my mind, skip_headers is a bool
Well, that's understandable... So, yet another change of name to skip_header_lines, skip_footer_lines, with the deprecation that goes with it ? More seriously, as it's been noted before, the change has been around for a while. Anyhow, it's up to y'all, as you see fit.

On Tue, Apr 5, 2011 at 5:52 PM, Ralf Gommers <ralf.gommers@googlemail.com> wrote:
On Tue, Apr 5, 2011 at 11:45 PM, Skipper Seabold <jsseabold@gmail.com> wrote:
On Sun, Apr 3, 2011 at 8:20 PM, Charles R Harris <charlesr.harris@gmail.com> wrote:
Should skiprows be removed?
if skiprows: warnings.warn(\ "The use of `skiprows` is deprecated, it will be removed in numpy 2.0.\n" \ "Please use `skip_header` instead.", DeprecationWarning) skip_header = skiprows
Its been deprecated since 1.4. Personally, I like skiprows better than skip_header ;)
+1 for skiprows. I always have to look it up.
To me one is not much better than the other, but -1 for skiprows because un-deprecating it and deprecating skip_header is inconsistent and annoying for users.
Ralf _______________________________________________ NumPy-Discussion mailing list NumPy-Discussion@scipy.org http://mail.scipy.org/mailman/listinfo/numpy-discussion
FYI: http://docs.python.org/library/warnings.html "DeprecationWarning Base category for warnings about deprecated features (ignored by default)." Maybe DeprecationWarnings should be changed to something that isn't ignored by default so users see it?

On Tue, Apr 5, 2011 at 18:20, Wes McKinney <wesmckinn@gmail.com> wrote:
FYI:
http://docs.python.org/library/warnings.html
"DeprecationWarning Base category for warnings about deprecated features (ignored by default)."
Maybe DeprecationWarnings should be changed to something that isn't ignored by default so users see it?
The Python devs made DeprecationWarnings silent by default for a reason. They unnecessarily annoy and frighten application end users who don't know what they are, where they are coming from, or how to silence them. The recommended practice is for library users (who do or should know those things) to run their test suites with the warnings turned on. -- Robert Kern "I have come to believe that the whole world is an enigma, a harmless enigma that is made terrible by our own mad attempt to interpret it as though it had an underlying truth." -- Umberto Eco

On Tue, Apr 5, 2011 at 7:32 PM, Robert Kern <robert.kern@gmail.com> wrote:
On Tue, Apr 5, 2011 at 18:20, Wes McKinney <wesmckinn@gmail.com> wrote:
FYI:
http://docs.python.org/library/warnings.html
"DeprecationWarning Base category for warnings about deprecated features (ignored by default)."
Maybe DeprecationWarnings should be changed to something that isn't ignored by default so users see it?
The Python devs made DeprecationWarnings silent by default for a reason. They unnecessarily annoy and frighten application end users who don't know what they are, where they are coming from, or how to silence them. The recommended practice is for library users (who do or should know those things) to run their test suites with the warnings turned on.
-- Robert Kern
"I have come to believe that the whole world is an enigma, a harmless enigma that is made terrible by our own mad attempt to interpret it as though it had an underlying truth." -- Umberto Eco _______________________________________________ NumPy-Discussion mailing list NumPy-Discussion@scipy.org http://mail.scipy.org/mailman/listinfo/numpy-discussion
You make a very convincing point-- makes complete sense.
participants (7)
-
Alan G Isaac
-
Charles R Harris
-
Pierre GM
-
Ralf Gommers
-
Robert Kern
-
Skipper Seabold
-
Wes McKinney