hi Alex, hi all, I don't have much time for things, about to leave on vacation. Just so that it doesn't get lost: on the unrolling-if branch, if you use the decorator, the JIT should *not* look inside the function if the condition if false. even if the function doesn't contain a loop. so maybe the decorators should be renamed to unroll_iff (too mathematical?) or unroll_exactly_if. Cheers, Carl Friedrich
Hi Carl, On Tue, Aug 2, 2011 at 10:20 AM, Carl Friedrich Bolz <cfbolz@gmx.de> wrote:
I don't have much time for things, about to leave on vacation. Just so that it doesn't get lost: on the unrolling-if branch, if you use the decorator, the JIT should *not* look inside the function if the condition if false. even if the function doesn't contain a loop. so maybe the decorators should be renamed to unroll_iff (too mathematical?) or unroll_exactly_if.
Then it has nothing to do with unrolling: it should be renamed to something like "look_inside_if". It just happens to mean, as a side-effect, "if the condition is true, then look inside even in case there is a loop, thus unrolling it". A bientôt, Armin.
On 08/02/2011 11:41 AM, Armin Rigo wrote:
Hi Carl,
On Tue, Aug 2, 2011 at 10:20 AM, Carl Friedrich Bolz<cfbolz@gmx.de> wrote:
I don't have much time for things, about to leave on vacation. Just so that it doesn't get lost: on the unrolling-if branch, if you use the decorator, the JIT should *not* look inside the function if the condition if false. even if the function doesn't contain a loop. so maybe the decorators should be renamed to unroll_iff (too mathematical?) or unroll_exactly_if.
Then it has nothing to do with unrolling: it should be renamed to something like "look_inside_if". It just happens to mean, as a side-effect, "if the condition is true, then look inside even in case there is a loop, thus unrolling it".
look_inside_iff then? :-) Carl Friedrich
On Tue, Aug 2, 2011 at 3:00 AM, Carl Friedrich Bolz <cfbolz@gmx.de> wrote:
On 08/02/2011 11:41 AM, Armin Rigo wrote:
Hi Carl,
On Tue, Aug 2, 2011 at 10:20 AM, Carl Friedrich Bolz<cfbolz@gmx.de> wrote:
I don't have much time for things, about to leave on vacation. Just so that it doesn't get lost: on the unrolling-if branch, if you use the decorator, the JIT should *not* look inside the function if the condition if false. even if the function doesn't contain a loop. so maybe the decorators should be renamed to unroll_iff (too mathematical?) or unroll_exactly_if.
Then it has nothing to do with unrolling: it should be renamed to something like "look_inside_if". It just happens to mean, as a side-effect, "if the condition is true, then look inside even in case there is a loop, thus unrolling it".
look_inside_iff then? :-)
Carl Friedrich
______________________________**_________________ pypy-dev mailing list pypy-dev@python.org http://mail.python.org/**mailman/listinfo/pypy-dev<http://mail.python.org/mailman/listinfo/pypy-dev>
Any of the above are fine with me :), I'll rename it when I next work on it. Alex -- "I disapprove of what you say, but I will defend to the death your right to say it." -- Evelyn Beatrice Hall (summarizing Voltaire) "The people's good is the highest law." -- Cicero
On 02/08/11 11:41, Armin Rigo wrote:
Then it has nothing to do with unrolling: it should be renamed to something like "look_inside_if". It just happens to mean, as a side-effect, "if the condition is true, then look inside even in case there is a loop, thus unrolling it".
look_inside_and_maybe_unroll_if?
participants (4)
-
Alex Gaynor
-
Antonio Cuni
-
Armin Rigo
-
Carl Friedrich Bolz